The referenced assembly "Microsoft.SharePoint.Client.Runtime" could not be resolved..

Error:
The referenced assembly "Microsoft.SharePoint.Client.Runtime" could not be resolved because it has a dependency on "System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" which is not in the currently targeted framework ".NETFramework,Version=v4.0,Profile=Client". Please remove references to assemblies not in the targeted framework or consider retargeting your project.

Fix:
When you get the above error, it means that in your project your pointing to .net framework 4.0 and its not installed in your machine. Now, change the project properties to point out available framework in your machine.

Comments